[gambit-list] Static GSI

Kirill Lisovsky k_lisovsky at yahoo.com
Sat May 16 10:18:56 EDT 2009


That's what file and ldd report on gsi compiled  on Ubuntu Linux
(no static/dynamic related options supplied to configure):

file gsi

gsi: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.8, dynamically linked (uses shared libs), not stripped

 ldd gsi 
        linux-gate.so.1 =>  (0xb7f9e000)
        libutil.so.1 => /lib/tls/i686/cmov/libutil.so.1 (0xb7f88000)
        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7f84000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7f5e000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7e0f000)
        /lib/ld-linux.so.2 (0xb7f9f000)

The problem is that such an executable may be incompatible with some  
another  Linux  - if it has some older version of libc, for example.  
 
I've tried explicit --disable-shared just in case, but it does not make gsi
static... 

Best regards,
               Kirill.


  

--- On Fri, 5/15/09, Bradley Lucier <lucier at math.purdue.edu> wrote:

From: Bradley Lucier <lucier at math.purdue.edu>
Subject: Re: [gambit-list] Static GSI
To: "Kirill Lisovsky" <k_lisovsky at yahoo.com>
Cc: "Bradley Lucier" <lucier at math.purdue.edu>, gambit-list at iro.umontreal.ca
Received: Friday, May 15, 2009, 11:02 PM



On May 15, 2009, at 11:37 PM, Kirill Lisovsky wrote:
I'd like to compile Gambit  interpreter as a static executable.
I think by default it's static (unless you configure with --enable-shaared).
Brad



      __________________________________________________________________
Make your browsing faster, safer, and easier with the new Internet Explorer® 8. Optimized for Yahoo! Get it Now for Free! at http://downloads.yahoo.com/ca/internetexplorer/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://webmail.iro.umontreal.ca/pipermail/gambit-list/attachments/20090516/2f5e9f14/attachment.html 


More information about the Gambit-list mailing list