[gambit-list] Gambit and

Ted Carroll ted.a.carroll at gmail.com
Fri Oct 2 01:34:23 EDT 2009


All --

I'm trying Gambit for the first time on my OS X Snow Leopard machine  
with XCode 3.2 and I'm getting errors (can't find limits.h).  If I set  
GAMBC_CC_VERBOSE=yes, the command line for gcc is the following:

 > gcc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -arch i386   -no-cpp- 
precomp -Wno-unused -O1 -fno-math-errno -fschedule-insns2 -fno- 
trapping-math -fno-strict-aliasing -fwrapv -fomit-frame-pointer -fPIC - 
fno-common -mieee-fp   -I"/Library/Gambit-C/v4.5.2/include" -c -o  
"foo.o"  foo.c

The problem (I guess) is that the listed SDK isn't installed.  Any way  
I can specify a different one?  Here are the ones installed:

 > ls /Developer/SDKs/
MacOSX10.5.sdk  MacOSX10.6.sdk

Thanks,

Ted C.


More information about the Gambit-list mailing list